Outdated List of Legions Launcher Bugs and Their Fixes


The latest version launcher is available for download here.
Preferably, open up the launcher as administrator, which downloads the necessary files. Clicking 'Play' will take you to the in-game menu.
Here are a few problems that are prone to happen, and their fixes:
*[Note 1: Before anything else, make sure that all the OS updates are complete, along with all the system drivers.]*
*[Note 2: Mac and Linux versions: http://forums.legionsoverdrive.com/threads/l-o-for-linux-and-mac.5008/]*
*[Note 3: A clear work-around for Linux is not yet out but if you need any help, contact 3lionz or Fireblasto on #legions (IRC).
*[Note 4: Please read the Blog for any launcher changes, passwords, updates etc.
*[Note 5: Network related issues? Read -
1) Log-in problems:
- Make sure you log-in with your new ID that you must create at this link - Account Registration.
Make sure you use your Account name, NOT the in-game playername that you entered, to log-in.

2) Login window doesn't close after launch:
- Re-updating the game will get it to close.

The latest version of the launcher no longer requires user accounts or login!

3) Microsoft .NET framework error:
- If the error looks something like this, click 'continue'.

3.1) Launcher.exe doesn't work:
- One of the most common problem. Make sure the Launcher download is of the latest version. (Link)
An error could occur that reads: The application failed to initialize properly (0xc0000135). Click on OK to terminate the application.
In that case, Install/update your .NET framework - Microsoft .NET Framework Version 2.0 Redistributable Package (x86) OR Microsoft .NET Framework 3.0 Redistributable Package OR Microsoft .NET Framework 4 (web installer).
If it still doesn't work, try restarting your computer, and other basic stuff that you know what to do (re-downloading the file etc.). If it still doesn't work, post or check below if any other solutions may work.

4) "Failed to locate D3DX dll": [Edit - If you have any run-time issues, other than the .dll error, try re-installing DirectX from the links below.]
- DirectX End User Runtime (Web Installer) or DirectX End-User Runtime Update. Be sure that your DirectX is up to date.

5) Legions crashes on clicking 'Join':
Ganyiki said:
I moved my paging file to a different partition and ran all the Windows updates. This included Microsoft .NET 1.1
6) Launcher stuck at 'Contacting Auth server'/just doesn't open at any point.

- Try the methods above. If none of them apply, thanks to Stefygraff, another method is available.
You can use this link (http://www.mediafire.com/file/jvg82do62db3839/live.zip).
Stefygraff said:
This is the link to the already installed launcher that worked for me, don't extract it. Open the launcher directly. After you play and close the updater, it will ask you if you want to save the modifications in the archive (do that). And there you are! Game working!
- Check to see if the computer time is synchronized with internet time. At-least that's what helped Carnage to stop whining over TS3 and start playing again. =P

7) Launcher doesn't update:

- Check to see that none of your files (reticles and other modifications) are set to 'Read-only'. Setting it to 'Read-only' doesn't let the launcher to update.
- Reboot your computer.

These are some of the most common problems that could occur. Make sure you go through them before posting your problem/bug, regarding the launcher.
**** Don't post your problems/bugs as a reply to this thread. If you are sure your problem/bug is new and is not in either the following thread or in any other posts in this section, then make a new thread. Thank you. Also, upload the console.log to the Bug Report you make. 'Search' function is your friend ;)
Have fun.

Last edited by a moderator:


Private Tester
Thank you. This was very needed as quite a few of the threads in this forum are duplicates or easily solved.


Private Tester
good thread, should expand it to include all known bugs/fixes so people dont have to search long and hard


Private Tester
#5 is my problem too and now the link to the fix is broken too.

I solved my problem by making sure my computer time was synchronised with internet time. Don't know if this will help anyone else.


you sure are taking your time fixing the dl link :/
Sorry SillyG0000se, that took time, yeah because of my really horrible connection. If daph can set up the link, it's all good, or I'll try asking someone else. Sorry again!
hey guys, you know when you open up the window to play the game, but first you needed to update it. What file do i need for that cos i can't play the game otherwise