Auto-Pan on movement of mouse.

Discussion in 'Bug Reports' started by Palton, Mar 26, 2016.

  1. Palton

    Palton New Member

    Few updates back (not sure which) the mouse? cursor? retical? view? starts auto-panning after mouse movements.

    Problem:
    Auto-Pans on either vertical axis(up or down) or horizontal axis never both(sideways).
    Movements of mouse whether long swipes or short sometimes causes it, sometimes doesn't, happens very frequently.
    It happens in spectator mode too.
    Right or Left-clicking stops the auto-panning, movement (WASD)does not.
    This doesn't happen in other FPS games.

    Attempted Fixes:
    Re-downloaded fresh copy, does not fix it.
    Removed mouse and played with touch pad still causes it.

    Comments:
    I did scroll through the forums, might have missed any similar problems.
    Did I somehow accidentally activate a permanent hidden auto-panning feature?
    For re-installation, do I have to delete all original files anywhere in the computer? Just downloading a fresh copy into a new folder would work right?
     
  2. Fixious

    Fixious Test Lead

    Could've sworn I read a similar post to this a while back, but I can't find it. The only thing I can think of is maybe you have a momentum setting turned on for your touchpad. But if it still happens with the touchpad disabled then it's something else. There's definitely an issue with mouse movement and certain GUIs, but that only seems to happen when fiddling around in LODC (demo mode). Perhaps it transferred over into the main game as well, though...

    What are your specs?

    Operating system, laptop model, mice model, etc.
     
  3. Palton

    Palton New Member

    Attempted Fixes:
    Read about windows 10/8 having problems with Touch pads due to Synaptics.
    Tried to access it under Mouse Settings, couldn't find it.
    Re-installed factory default Synaptics driver worked.
    There were options to disable Touch Pad vertical/horizontal scrolling.
    Did so, no effect on the problem in the game.

    Specs:
    OS - Windows 10 (Originally bought with Windows 8 - sneaky Microsoft caught me with the update)
    Laptop - Acer Aspire v3-571G
    Mouse - Steelseries Kinzu v2
    etc?
    Touchpad - Unsure how to check?
    Under -
    Mouse Properties > Hardware > Devices: Synaptics PS/2 TouchPad
    Mouse Properties > Device Settings(Synaptics) > Devices: Synaptics TouchPad V7.4 on PS/2 Port
     
  4. Fixious

    Fixious Test Lead

    I'm not aware of anything specific in Legions that would cause this, so we can try a few common fixes for this regarding the mouse itself.

    Clean the mouse, specifically where the lens. A bit of dirt can cause some issues. A Q-tip or something similar should suffice.
    Uncheck pointer precision if it's checked.

    [​IMG]

    Disable Momentum if you have a setting like that for your touchpad.

    [​IMG]
    Try a different USB port.
    Try a different mouse if you have a spare one laying around.
    Uninstall the device/drivers and reinstall it. It could be a driver issue.
     
  5. Palton

    Palton New Member

    Attempted Fixes:
    Disabled Momentum
    Disabled EdgeMotion
    Unchecked pointer precision
    Cleaned Mouse lens with a wet then dry Q-tip.
    Switched Mouse to different usb ports or no usb ports(Touch Pad)
    Disabled Touch pad and mouse.
    Reinstalled all Mouse Drivers.
    Restarts after changes are made.
    Doesn't work. :(

    Comments:
    Think this problem happened before upgrading to windows 10.
    It was working fine for the past few years. Screenshot.png