Launcher Stops Responding After I Click Join


Since the last update, if I were to click play on the legions launcher then the launcher would stop responding, and I would have to close it via the task manager. For whatever reason, I had about 3 different downloads of L:O on my laptop, and I tried the launcher of each download until one worked and I could get into the game, with no single launcher working every time I clicked play. This worked for a few days, until the 13/02/16, when nothing I did would stop the launcher from ceasing to respond when I clicked play.

When I tried deleting all my copies of L:O, 2 of them went fine, but one of them (the only copy where I had tried opening legions.exe) wouldn't delete as a file was still open somewhere. I narrowed down the file to be legions.exe, and when I tried to delete it, a pop-up said "The action can't be completed because the file is open in System" "Close the file and try again [to delete]". The only way I could get past this was by restarting my laptop and deleting the file before I opened it. Nothing legions-related would appear in task manager.

I then tried installing L:O into a fresh folder on my desktop (with no other copies of L:O on this laptop), but the same thing would happen; the launcher would stop responding when I click play. I then tried to open legions.exe, which had no effect bar when I hovered my mouse over the 'game' file it would indicate something was loading. If I ran it as an admin/right-click opened it, the game folder would stop responding.

Older versions of legions do work for me.

System specs:

Screenshots of the effects mentioned above:

Sorry if any/all of this doesn't make sense; it's 3am. RIP pugging


Shows nothing wrong with the launcher - try and launch legions.exe directly to see what problems there are.


So what should I try doing? Would this be easier to do on IRC?

Edit: I don't know how or why, but this issue has resolved itself. I didn't change anything, try launching it a different way, delete/add anything, or even turn off/restart my laptop, it just started to work again. Thanks for the help though, Greaper.
Last edited: