:| I don't even..


In the whole life of legions i've never had a problem with launching the game until this week when i re-downloaded it. Now when i launch by the updater or the legions.exe it hangs, it doesn't crash or show as not responding. It shows as an active running process but never appears. I've looked into all the help threads but nothing mentioned matches my case. My logs show nothing out of the ordinary either.

The only thing i've done since the last time i was able to launch the game was replace my cpu and some display driver updates.

OS: Windows 7 64 bit Home Premium
Processor: AMD 9590 Vishera 8-Core Black Edition @ 5.2 GHz
Mother Board: GIGABYTE GA-990FXA-UD7
Memory: 32GB G.Skill RipJaws Sniper DDR3
Video Card: Radeon R9 380 4GB GDDR5


Test Lead
Not a lot to go by. Could try compatibility mode, running as admin, redownloading the DirectX stuff, etc. I've got a few older builds laying around we can try as a last resort.


Yeah tried all of that even older builds i found here on the forums that stefy had posted. Thats why its so strange, there is no reason it shouldn't launch.. Might try to roll back drivers.

Rolled back a few drivers to around the last time i played. works now.. not sure why.. not questioning it.
Last edited: