Legions.exe has stopped working.

Discussion in 'Bug Reports' started by Inc, Jan 18, 2011.

  1. Inc

    Inc New Member

    The legions application crashes once I hit the Play button. I get the "Legions.exe has stopped working. Windows is checking for a solution to the problem". No console.log found in the live folder.

    Specs:
    Windows Vista SP2
    Intel Core 2 Duo Processor E6850 @ 3.00GHZ
    ATI Radeon HD 2600 XT
    Direct X 11
    3GB RAM
    32bit

    Tried Solutions:
    - Update Drivers
    - Update DirectX
    - Direct X 9.0c Redistributable
    - Run As Administrator
    - Delete/Reinstall Legions
    - .NET Installs Microsoft .NET Framework 3.0 Redistributable Package and Microsoft .NET Framework 4 (web installer)
    -Run as compatibility XP

    Any help would be appreciated!

    Thanks,
    Michael (57th-Inc)
     
  2. Gheist

    Gheist King of all Goblins

    .net version?
     
  3. Inc

    Inc New Member

    I forgot to include trying to install the .NET installers from the sticky post (I edited my original post to keep track). This may be an area where I need help. When I was in college, I did some development using Visual Studio 2005. If I go to my installed programs, I have the following installed related to .NET Framework:
    - Microsoft .NET Compact Framework 1.0 SP3 Developer
    - Microsoft .NET Compact Framework 2.0
    - Microsoft .NET Framework 1.1
    - Microsoft .NET Framework 3.5 SP1
    - Microsoft .NET Framework 4 Client Profile
    - Microsoft .NET Framework 4 Extended
     
  4. Fixious

    Fixious Test Lead

    I kept getting this after I installed FlagHUD. Relaunching the game usually fixes the issue, but it's still annoying.
     
  5. LunarSolstice

    LunarSolstice Member

    32- or 64-bit?
    Try going to the legions.exe in the directory and right click on it, go to Preferences, under Compatibility (might not be a tab but it's easy to find), check Windows XP something and see if it works then.
     
  6. Inc

    Inc New Member

    32bit and compatibility change did not work. Thanks!
     
  7. djberlin

    djberlin New Member

    Does the same thing for me.
     
  8. juhben

    juhben New Member

    I clicked Play then " There's an error, Cannot Load All Game Mods "
     
  9. Clide

    Clide New Member

    Post removed to avoid confusion.
     
  10. RockeyRex

    RockeyRex Legions Developer

    The complete log please.
    Also that error shouldn't be it. That's something everyone should be getting at the moment.
     
  11. Inc

    Inc New Member

    Bringing the thread back to it's original purpose:

    The legions application crashes once I hit the Play button. I get the "Legions.exe has stopped working. Windows is checking for a solution to the problem". No console.log found in the live folder.

    Specs:
    Windows Vista SP2
    Intel Core 2 Duo Processor E6850 @ 3.00GHZ
    ATI Radeon HD 2600 XT
    Direct X 11
    3GB RAM
    32bit

    Tried Solutions:
    - Update Drivers
    - Update DirectX
    - Direct X 9.0c Redistributable
    - Run As Administrator
    - Delete/Reinstall Legions
    - .NET Installs Microsoft .NET Framework 3.0 Redistributable Package and Microsoft .NET Framework 4 (web installer)
    -Run as compatibility XP

    Any help would be appreciated!
     
  12. Inc

    Inc New Member

    Bump
     
  13. Daphinicus

    Daphinicus Private Tester

    Damn, Inc, you're in quite the pickle. Looks like you've tried every reasonable fix, and nothing's working.

    if there's no console.log available, how about a dxdiag? get that baby up here and we'll see if we can spot any reason why you might be running into these issues.
     
  14. Inc

    Inc New Member

    See attached. Thanks so much!
     

    Attached Files:

  15. Tristan123

    Tristan123 New Member

    I have the same problem. I really want to play legions again but The application crash everytime I click the play button. I attached a Dxdiag here. Thank you very much.
     

    Attached Files:

  16. SeymourGore

    SeymourGore Flatulent Cherub

    Yar, unfortunately that Intel integrated graphics chipset is kinda hit or miss with Legions (some people have gotten them to work, albeit at a lower performance), and were not supported by Legions for this reason.
     
  17. Inc

    Inc New Member

    Thanks Seymour. Does that feedback also apply to me?
     
  18. SeymourGore

    SeymourGore Flatulent Cherub

    Nope, you're using a dedicated GPU. AFAIK, the 2600 series should run Legions: Overdrive adequately.
     
  19. Ascetic

    Ascetic New Member

    I have the same issue. I do have a console.log file though. I have Windows 7 64 bit fully patched with .Net 4. I have the latest driver installed on my HD 4800.

    Fallen Empire: Legions - 2/10/2011 - 18:24:07

    Checking for unused arguments...
    Checking switch "log-mode"...
    Checking switch "uid"...
    Checking switch "sessid"...
    Checking switch "modified"...
    Error: Unknown command line switch: "modified".
    Checking switch "nick"...
    Error: Unknown command line switch: "nick".

    Loading game scripts...
    Loading Legions common scripts...
    Loading client scripts...
    Missing file: C:/Users/Jason/Desktop/live/client/scripts/utility.cs!
    Loading gui scripts...
    Loading script path "client/gui/profiles/" with extensions "cs^ts^gui"
    Built pattern client/gui/profiles/*.cs^client/gui/profiles/*.ts^client/gui/profiles/*.gui^
    Compiling files...
    Executing compiled dso files...
    - Executing client/gui/profiles/serverBrowser.cs.dso
    - Executing client/gui/profiles/scoreboard.cs.dso
    - Executing client/gui/profiles/menus.cs.dso
    - Executing client/gui/profiles/loading.cs.dso
    - Executing client/gui/profiles/gameHud.cs.dso
    - Executing client/gui/profiles/fpsDisplay.cs.dso
    - Executing client/gui/profiles/console.cs.dso

    Loading script path "client/gui/scripts/" with extensions "cs^ts^gui"
    Built pattern client/gui/scripts/*.cs^client/gui/scripts/*.ts^client/gui/scripts/*.gui^
    Compiling files...
    Executing compiled dso files...
    - Executing client/gui/scripts/videoOptions.cs.dso
    - Executing client/gui/scripts/serverQuery.cs.dso
    - Executing client/gui/scripts/serverBrowser.cs.dso
    - Executing client/gui/scripts/scoreboard.cs.dso
    - Executing client/gui/scripts/pause.cs.dso
    - Executing client/gui/scripts/messageBox.cs.dso
    - Executing client/gui/scripts/mainMenu.cs.dso
    - Executing client/gui/scripts/loading.cs.dso
    - Executing client/gui/scripts/keybindings.cs.dso
    - Executing client/gui/scripts/hudElements.cs.dso
    - Executing client/gui/scripts/gameOptions.cs.dso
    - Executing client/gui/scripts/gameHud.cs.dso
    - Executing client/gui/scripts/fpsDisplay.cs.dso
    - Executing client/gui/scripts/connect.cs.dso
    - Executing client/gui/scripts/classSelection.cs.dso

    Loading script path "mods/autoexec/" with extensions "cs^ts^gui"
    Built pattern mods/autoexec/*.cs^mods/autoexec/*.ts^mods/autoexec/*.gui^
    Compiling files...
    Executing compiled dso files...

    Initializing game...
    Network Init:
    Binding server port to default IP
    UDP initialized on port 0

    DirectX Init:
    Version 10.0.0
    Creating GFX device ATI Radeon HD 4800 Series (D3D9)
    Using 'd3dx9_42.dll' for D3DX
    D3DDevice ref count is 1
    Pixel shader version: 3.000000
    Vertex shader version: 3.000000
    Texture samplers: 8
    Initializing GFXCardProfiler (D3D9)
    o Description: 'ATI Radeon HD 4800 Series '
    o Vendor : '4098'
    o Product : '8'
    o Version : '17'
    o Subversion : '10'
    o Build : '1063'
    o DeviceId : '{D7B71EE2-D700-11CF-1070-0D00BEC2C535}'
    - Scanning card capabilities...
    GFXCardProfiler (D3D9) - Setting capability 'autoMipMapLevel' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'maxTextureWidth' to 8192.
    GFXCardProfiler (D3D9) - Setting capability 'maxTextureHeight' to 8192.
    GFXCardProfiler (D3D9) - Setting capability 'maxTextureSize' to 8192.
    GFXCardProfiler (D3D9) - Setting capability 'maxRenderTargets' to 4.
    GFXCardProfiler (D3D9) - Setting capability 'lerpDetailBlend' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'fourStageDetailBlend' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'R8G8B8_Fmt_Ok' to 0.
    GFXCardProfiler (D3D9) - Setting capability 'A8_Fmt_Ok' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'DXT1_Fmt_Ok' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'DXT2_Fmt_Ok' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'DXT3_Fmt_Ok' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'DXT4_Fmt_Ok' to 1.
    GFXCardProfiler (D3D9) - Setting capability 'DXT5_Fmt_Ok' to 1.
    Missing file: C:/Users/Jason/Desktop/live/profile/profile.cs!
    SFX Init
    ConsoleDetail::print - Invalid level argument: "".
    ConsoleDetail::print - Invalid level argument: "".
    ConsoleDetail::print - Invalid level argument: "".
    ConsoleDetail::print - Invalid level argument: "".
    Initializing volume settings...
    Setting master volume to 0.8
    Setting channel 1 volume to 0.8
    Setting channel 2 volume to 0.8
    Setting channel 3 volume to 0.45
    Setting channel 4 volume to 0.5
    Setting channel 5 volume to 0
    Setting channel 6 volume to 0
    Setting channel 7 volume to 0
    Setting channel 8 volume to 0

    Loading audio scripts...
    Loading guis...
    Loading script path "client/gui/guis/" with extensions "cs^ts^gui"
    Built pattern client/gui/guis/*.cs^client/gui/guis/*.ts^client/gui/guis/*.gui^
    Compiling files...
    Executing compiled dso files...
    - Executing client/gui/guis/videoOptions.gui.dso
    Texture Manager
    - Approx. Available VRAM: -1354760192
    - Threshold VRAM: 67108864
    - Max Texture Size: 0
    - Amount used since last Texture Manager validation: 0 (0.00 MB)
    Quality mode: high

    - Executing client/gui/guis/serverBrowser.gui.dso
    - Executing client/gui/guis/scoreboard.gui.dso
    - Executing client/gui/guis/remap.gui.dso
    - Executing client/gui/guis/pause.gui.dso
    - Executing client/gui/guis/messageBoxes/messagePopup.gui.dso
    - Executing client/gui/guis/messageBoxes/messageBoxYesNoCancel.gui.dso
    - Executing client/gui/guis/messageBoxes/messageBoxYesNo.gui.dso
    - Executing client/gui/guis/messageBoxes/MessageBoxOKCancelDetailsDlg.gui.dso
    - Executing client/gui/guis/messageBoxes/messageBoxOkCancel.gui.dso
    - Executing client/gui/guis/messageBoxes/messageBoxOk.gui.dso
    - Executing client/gui/guis/menuBackground.gui.dso
    - Executing client/gui/guis/mainMenuBackground.gui.dso
    - Executing client/gui/guis/mainMenu.gui.dso
    Namespace::unlinkClass - cannot unlink namespace parent linkage for OptionsButton for GuiBitmapButtonCtrl.
    Error: cannot change namespace parent linkage of OptionsButton from GuiBitmapButtonCtrl to GuiBitmapButtonTextCtrl.
    - Executing client/gui/guis/loadingBackground.gui.dso
    - Executing client/gui/guis/loading.gui.dso
    - Executing client/gui/guis/keybindings.gui.dso
    - Executing client/gui/guis/gameOptions.gui.dso
    - Executing client/gui/guis/gameHud.gui.dso
    - Executing client/gui/guis/fpsDisplay.gui.dso
    - Executing client/gui/guis/console.gui.dso
    - Executing client/gui/guis/connect.gui.dso
    - Executing client/gui/guis/chat.gui.dso

    Loading script path "client/shaders/" with extensions "cs^ts^gui"
    Built pattern client/shaders/*.cs^client/shaders/*.ts^client/shaders/*.gui^
    Compiling files...
    Executing compiled dso files...
     
  20. Clide

    Clide New Member

    Ascetic, try updating your DirectX version to 11, it worked for me.
    Check it out over in this thread.